尘缘版接口 提示This file has expired的解决办法

各位新老用户注意咯:
自2011-10-07日起,本帖所发布免费接口也发布到尘缘的授权中心了,各位可以免费下载,无需注册。
下载免费接口、购买收费接口、更新收费接口的用户请直接前往http://my.4wei.cn
主是要考虑到由于平时时间紧,更新接口以后需要修改多个帖子的版本号,比较麻烦。
现在把接口放到一起,接口的更新就统一在授权中心进行通知了。
以后接口的更新日志不在本帖发布,有BUG或者接口提示This file has expired.需要更新接口的用户请前往授权下载页面

今天很多使用以前手工授权的收费和免费用户,都出现了This file has expired的提示,原因是前两年前手工使用的zend guard进行授权,里面有一个过期时间,可以设置接口在一定时间可以停止使用。
当时想的是未来两年接口可能已经更新过很多版本,用户下载使用的肯定是0最新的接口。
现在来看,很多用户不太愿意升级他们使用的接口,刚刚还有6.x和7.x的用户来找我索要最新版。

还有几个两三年前的老用户也来联系尘缘了,久违呀!这些用户有的还保持着每天采集4万帖的频率,吼吼。看到自己的产品有这么多忠实的用户,心里还是挺高兴的。

谢谢各位支持呐。

各位使用很古老版本的用户,请到授权中心更新一下你的接口版本。
更新方法:

  1. 主程序,locoy.php是必须的覆盖的
  2. 配置文件,locoy.config.php一般不需要更新,部分接口有新的功能加入,需要更新配置信息,可以对比一下两个配置文件
  3. 其它的发布模块、规则不需要更新

授权地址:http://my.4wei.cn
免费接口也需要走购买流程,只是不需要付款,收费接口直接输入域名即可下载授权,如果是前几年手工添加的授权,请联系尘缘更新授权记录,再更新授权。
以下是几张图片演示过程:




发表评论

电子邮件地址不会被公开。